Get an Epic Experience with Premium

Archaeology Helper

Archaeology Login to Add Favorites
  • 38 Likes
  • World of Warcraft
  • 12,985 Monthly Downloads
  • Supports: 5.4.2
  • 1,037,773 Total Downloads
  • Updated 02/14/2014
  • Created 12/17/2010
  • 1,248 Favorites
  • Project Site
  • Comments
  • Release Type: Release
  • License: All Rights Reserved
  • Newest File: 1.3.0
or
Support development! **
Donate

About Archaeology Helper

Archaeology Helper accelerates your surveying by providing triangulation on a Heads-Up Display (HUD)

  • Survey then press green, yellow or red button to add new sector to the HUD and narrow down the position of your fragment
  • HUD optionally includes GatherMate2 pins showing possible fragment positions, further accelerating the process
  • Shows Dig Sites on Battlefield Minimap
  • Keybindings and various settings

How to use

Go to dig site, Right Click last button (spade) to show HUD and Left Click to cast Survay. Then ROTATE YOUR CHAR, BUT DON'T MOVE in the needed direction and press colored button according to Survey result. Move to other location, do same again.
It is strongly recommended to use in conjunction with GatherMate2, which will show all previous or imported dig-points on the HUD. When using GatherMate2 jump onto fragment before gathering! GatherMate2 data accuracy depends on that. Minimap zoom buttons also zoom the HUD display.

Controls

Left Click main window to move it
Right Click main window: opens config

Left Click on colored button: adds new sector to the HUD
Right Click on colored button: temporarily hide/show that color

Arrow button: undo last sector

Left Click spade: cast Survey
Right Click spade: show/hide the HUD
Middle Click spade: open Archaeology window

Use "/arh" or "/arhcfg" for command line help

HUD

On the HUD you can also see player arrow in the center and very small red circle that represents survey success range. And ofc all colored transparent overlapping areas that were set by you with colored buttons.

How to help

------------------------------------------------------------------------
r67 | oscarucb | 2014-02-14 19:29:59 +0000 (Fri, 14 Feb 2014) | 1 line
Changed paths:
   A /tags/1.3.0 (from /trunk:66)

Tagging as 1.3.0
------------------------------------------------------------------------
r65 | oscarucb | 2014-02-12 12:00:15 +0000 (Wed, 12 Feb 2014) | 2 lines
Changed paths:
   M /trunk/arh.lua

improve digsite autotoggle

------------------------------------------------------------------------
r64 | oscarucb | 2014-02-11 15:03:01 +0000 (Tue, 11 Feb 2014) | 2 lines
Changed paths:
   M /trunk/arh.lua

add option to auto-toggle the window with the new digsite progress bar

------------------------------------------------------------------------

Comments

First Previous Page 17 of 21 Next Last
  • #65
    Yes, i wanted it myself. But Blizzard does not offer any way to rotate their DigSites Frame. And it is technically very hard (comparable to current) to do it by myself. I'll probably end up with own drawing, but that will be later.
  • #51
    Since installing this AddOn the red dig site areas show on my minimap (which is cool) but they go beyond my minimap... If the site is in the same zone and is south west the the red area is smack in the middle of my screen.... sooooo annoying...
  • #54
    It's problem with blizzard's DigSites Frame. Can't solve in near future, maybe later. Or if blizzard fix their frame.

    You can use "/arh mm" to toggle it on minimap.
  • #50
    The latest version broke quite a few of my mods (Bartneder4, Minimap Button Frame, ArkInventory, and some others) not sure why....
    And I'm 100% sure it was Archeo Helper, I started disabling my most recently updated mods 1 by 1 and when I disabled it, everything started working fine and continued to work fine after I re-enabled everyhting else.

    Hope this gets sorted out soon as I love this mod dearly.
  • #53
    I am using ArkInventory myself and it works for me.
    Can you say what version of ArkInventory does not work with "0.81" version of my addon. And what exactly does not work? So i could test it with just 2 addons enabled.
  • #56
    I got the same issue, disabled this addon for now.

    First Error:
    Message: ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:20: Cannot find a library instance of "AceGUI-3.0".
    Time: 12/22/10 13:06:29
    Count: 1
    Stack: [C]: in function `error'
    Interface\AddOns\Arh\libs\LibStub\LibStub.lua:23: in function `LibStub'
    ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:20: in main chunk

    Locals: (*temporary) = "Cannot find a library instance of "AceGUI-3.0"."

    I get a total of 44, but I don't know if all are from this mod. I've been flooded with LUA errors ever since cata hit lol.

    ArkInventory tries to load translations up to 7 of 5 times, then stops trying. Leaving me with empty bags and NO DATA.

    It's definitely this addon though.
  • #59
    as for ArkInventory:
    bags look ok when i enable "ArkInventory 3.02.72" and "Archaeology Helper 0.82" only.
    btw even when i leave ArkInventory alone it tries to load translations up to 5 times, so it must be normal. maybe.
  • #63
    Works fine with everything now. Ty for the fix and keep up the great work/development.
  • #58
    should be ok in the "version 0.82"
  • #57
    Oh and, using ArkInventory 3.02.72.

    Something else, love your mod. Needs some modification here and there, but it's really nice to use while digging. I, for one, am actually pleased that those digzones show outside of the minimap, that way I don't have to open the Map all the time. Might want to keep that as option if you ever get to fix it (or blizzard)
    Great mod, keep it up ;)
  • #49
    seeing some transparency settings in it now- however, a minimap arrow towards closest digsite, is that impoissible 2 write into it? would b nice imo hehe :)

    great addon, takes a bit 2 learn as anything else i sopose- thx for this biashanord
    /hail
  • #48
    Great addon! I have only one issue. Cant get the settings page to come up. Tried right clicking on the main window and nothing happens. Any thoughts?

    Keep up the good work!
  • #52
    Try to press "Esc" to show wow "Options" window.
    Press "Interface" button.
    Switch left panel to "AddOns" tab.
    Select "Arh" in the list.

    If it does not work, try "/arhcfg" in chat.
  • #62
    Whatever it was its fixed now with the update. I believe maybe it was conflicting with another addon.

    Thanks a bunch!
  • #37
    Very nice addon, my only suggestion would be to make an option for transparancy on the HUD, sometimes it can be a bit faint..
  • To post a comment, please login or register a new account.
Login to Curse

Don't have an account? Create One.

Get an epic experience with Curse Premium
  • Faster addon downloads
  • Premium-Only Beta Giveaways
  • Ad-Free Curse experience
  • Premium Curse Client
  • and many More Features
  • Learn More »

Alienware Alpha Giveaway!