Get an Epic Experience with Premium

ArkInventory

Bags & Inventory Login to Add Favorites
  • 104 Likes
  • World of Warcraft
  • 35,222 Monthly Downloads
  • Supports: 5.4.7
  • 6,105,400 Total Downloads
  • Updated 03/19/2014
  • Created 12/23/2006
  • 5,554 Favorites
  • Project Site
  • Comments
  • Release Type: Release
  • License: All Rights Reserved
  • Newest File: 3.03.33
or
Support development! **
Donate

About ArkInventory

the FAQ is here http://code.google.com/p/arkinventory/wiki/FAQ

the wiki is here http://code.google.com/p/arkinventory/w/list

to see how you need to setup sorting go here http://code.google.com/p/arkinventory/wiki/UserGuide_HowTo_Sorting

to see how to setup rules go here http://code.google.com/p/arkinventory/wiki/RuleFunction

please ensure you have read those before you lodge a ticket at http://code.google.com/p/arkinventory/issues/list


when posting a comment about an error do not include the list of addons, just the actual error and trace is fine.


AI's display windows are built from "virtual bars", you assign categories to bars so that items in that category are displayed on the specific bars you want. There is no limit to the number of bars you can have inside a window but obviously you only have so much screen real estate before it becomes "too many".

AI uses several methods to assign a default category to an item such as what professions you have, tooltip scanning, basic type/subtype and PeriodicTable. You then assign those categories to a virtual bar.

You can also over-ride the default category by creating a rule that matches either a single or multiple items.

Overview:

  • unlimited number of bars (there are practical limits though before your screen becomes full)
  • assign items to a category of your choice (overrides the default assignment)
  • assign categories to the bar of your choice
  • configurable bars per row
  • configurable width
  • separate keybindings for bag, keyring and bank viewing


Key Bindings:
Press ESCAPE to bring up the blizzard menu
click on Key Bindings
scroll down to ArkInventory
bind the keys you want to use

See ReadMe.txt and VersionHistory.txt for further details

Beta Versions:

ensure you make a backup copy of your saved variables file before installing a beta version - you normally cannot revert back to the release version without that backup. your saved variable file is normally located in World of Warcraft\WTF\Account\yourwowaccountname\SavedVariables\ArkInventory.lua

if you have the curse client set to download beta versions then it is your responsibility to ensure you have adequate backups of your saved variables file - do not complain if you lose them or they get screwed up because you installed a beta version, its what beta versions tend to do.

a simple way to back it up is to just do a copy and paste then rename the new file (using the version number of AI is a good idea), eg ArkInventory-3-01-09.lua

------------------------------------------------------------------------
r421 | arkayenro | 2014-03-19 10:38:59 +0000 (Wed, 19 Mar 2014) | 4 lines
Changed paths:
   A /tags/3.03.33 (from /trunk:420)

*3.03.33 (19-MAR-2013)*
 * fixed - mount availability code when zoning
 * added - locales for itIT and ptBR

------------------------------------------------------------------------
r420 | arkayenro | 2014-03-19 10:34:32 +0000 (Wed, 19 Mar 2014) | 4 lines
Changed paths:
   A /trunk/Locale/itIT.lua
   A /trunk/Locale/ptBR.lua
   D /trunk/Modules/ArkInventoryRulesExample

*3.03.33 (19-MAR-2013)*
 * fixed - mount availability code when zoning
 * added - locales for itIT and ptBR

------------------------------------------------------------------------
r419 | arkayenro | 2014-03-19 10:27:41 +0000 (Wed, 19 Mar 2014) | 4 lines
Changed paths:
   M /trunk/.pkgmeta
   M /trunk/ArkInventory.lua
   M /trunk/ArkInventory.toc
   M /trunk/Locale/deDE.lua
   M /trunk/Locale/enUS.lua
   M /trunk/Locale/esES.lua
   M /trunk/Locale/esMX.lua
   M /trunk/Locale/frFR.lua
   M /trunk/Locale/koKR.lua
   M /trunk/Locale/locale.xml
   M /trunk/Locale/ruRU.lua
   M /trunk/Locale/zhCN.lua
   M /trunk/Locale/zhTW.lua
   M /trunk/Modules/ArkInventoryRules/ArkInventoryRules.lua
   M /trunk/VersionHistory.txt

*3.03.33 (19-MAR-2013)*
 * fixed - mount availability code when zoning
 * added - locales for itIT and ptBR

------------------------------------------------------------------------
r418 | arkayenro | 2014-02-28 04:29:39 +0000 (Fri, 28 Feb 2014) | 2 lines
Changed paths:
   M /trunk/ArkInventory.toc

ArkInventory:
-
------------------------------------------------------------------------
r417 | arkayenro | 2014-02-28 00:52:47 +0000 (Fri, 28 Feb 2014) | 2 lines
Changed paths:
   M /trunk/ArkInventory.toc

ArkInventory:
- alpha 20140228
------------------------------------------------------------------------
r416 | arkayenro | 2014-02-28 00:49:26 +0000 (Fri, 28 Feb 2014) | 2 lines
Changed paths:
   M /trunk/ArkInventory.lua
   M /trunk/ArkInventory.toc
   M /trunk/ArkInventoryLDB.lua
   M /trunk/ArkInventoryStorage.lua
   M /trunk/VersionHistory.txt

ArkInventory:
- alpha commit to fix issue with mounts
------------------------------------------------------------------------

Comments

First Previous Page 50 of 283 Next Last
  • #4017

    Having the same issues as those below in regards to Auction House LAG. i post a lot, around 5-900 auctions a day, its taken me acouple of weeks to figure out that it was AI causeing me the lag grief. i have turned of almost every other add on i have to pin point it, but with AI running i cant post on the AH, it takes an extra hour and is infuriating. It affects auctionator, TSM and auctioneer all of which i assumed was the problem until this mornig i turned off AI and hey presto NO MORE LAG!!!!! AI def causing the problem, and i will be sore missed without it, its such a wonderful addition to my core Addon group

  • #4019

    i dont know what to say, with only AI running i just posted 24 auctions (not a lot but enough that the issue should have shown up) and spun my character in a circle (held down the left arrow), with the bag open, there were no lag spikes at all while those auctions were posted.

     

    try this.  open the config and go to controls > auctions - and disable the monitor option, that will stop AI from scanning the AH (ie no code will run while at the AH, except for normal bag updates)

    Last edited by Arkayenro on 8/30/2012 11:20:06 PM
  • #4021
    Quote from camerontweedle »

    This fixed it for me. It's a good thing, too, because I tried a couple different bag addons and neither came close in terms of feature and design. All is right in the world again. FWIW - it does sound like Blizzard screwed a bunch of stuff up with the AH sorting methods this patch, so there probably isn't even a lot you can do to fix it.

    Thanks for the workaround, though. Back in business

     

    This fixed it for me too! YAY!

  • #4020

    This fixed it for me. It's a good thing, too, because I tried a couple different bag addons and neither came close in terms of feature and design. All is right in the world again. FWIW - it does sound like Blizzard screwed a bunch of stuff up with the AH sorting methods this patch, so there probably isn't even a lot you can do to fix it.

    Thanks for the workaround, though. Back in business

  • #4018

    This is exactly what is happening to me too (with my comments below), I have turned off every addon one at a time, and it's definately AI that is doing it.  Now that I have upgraded to the most recent version, I'm no longer getting any LUA errors....but the lag is still there.  I'm literally getting 15-25 seconds of UI freezing every 5 or so seconds, it's taking forever to do anything at the AH (mailbox is now fine).

  • #4013

    Every time I get a ready check in raid, I get the following message on screen - seems like its probably an Ace3 issue however.

    Message: AceTimer-3.0: CancelTimer(handle[, silent]): 'table: 0x1b3eef518' - no such timer registered
    Debug:
       (tail call): ?
       ...rkInventory\Externals\Ace3-AceTimer\AceTimer-3.0.lua:327: CancelTimer()
       Grid\GridCore.lua:302: StopTimer()
       ...erface\AddOns\Grid\Statuses\GridStatusReadyCheck.lua:200: ?()
       ...ventory\Libs\CallbackHandler\CallbackHandler-1.0.lua:146:
          ...ventory\Libs\CallbackHandler\CallbackHandler-1.0.lua:146
       [string "safecall Dispatcher[3]"]:4:
          [string "safecall Dispatcher[3]"]:4
       [C]: ?
       [string "safecall Dispatcher[3]"]:13: ?()
       ...ventory\Libs\CallbackHandler\CallbackHandler-1.0.lua:91: Fire()
       ...rkInventory\Externals\Ace3-AceEvent\AceEvent-3.0.lua:120:
          ...rkInventory\Externals\Ace3-AceEvent\AceEvent-3.0.lua:119

  • #4015

    this would be an issue with grid, either update the mod or report it to the author

  • #4012

    I find that my some rules for my item sets are not working, these were working in the previous version and SOME of them are working, some are not.

    Any suggestions?

  • #4023

    Try editing a rule. This made all theg rules work properly for me.

  • #4011
    help me pls if you can....

    hello all ... I installed the latest version, but I have problems with the color of the item in the bag, look..this images...

    http://s15.postimage.org/c8odtdrwr/before.jpg

    and now

    http://s16.postimage.org/hf5i4b5qt/after.jpg

    As you can see the edges of the items have changed color as the BOE and the epic GEMS, can you help me pls...

    tx

     

  • #4002

    The new releases are causing an extreme amount of lag when I try to post auctions and get my mail.  This is been happening for the last few updates, and I keep having to revert to an earlier version.  I saw one other commentor below had the same issue.  I'm not sure what is causing it, not seeing any lua errors.  I hope whatever it is can be resolved though, b/c I LOVE your addon and I find it vital to my AH business :)

  • #4004

    im not getting that on any of the previous versions and ive been posting a lot of auctions of late (and also picking up a lot of mail).

    if possible try with just AI running and post some auctions, or get your mail and if the issue is still there let me know.  either way its going to be hard to find something that causes spikes, especially when nothing in the mail or auction scan code has been changed for a long time.

    alternatively you could also try taking a backup of the saved variable file for AI and then removing it.  start with the default config and see if the lag is still there when picking up mail.

  • #4016

    i know what you mean, every now and then you get a small spike when something leaves the bag - my problem is that if i remove all addons and only have AddonControlPanel and ArkInventory loaded then it doesnt seem to happen.

  • #4014

    I'm having this same issue. Only disabling ArkInventory relieves the lag. The issue seems to be caused when actually POSTING items, so I suspect it has something to do with the items leaving the bag inventory.

  • #4010

    Alright I will try that.  It was doing the same thing with the new version as well...I'll upgrade again and post the errors I get (if I still get them)

  • To post a comment, please login or register a new account.
Login to Curse

Don't have an account? Create One.

Get an epic experience with Curse Premium
  • Faster addon downloads
  • Premium-Only Beta Giveaways
  • Ad-Free Curse experience
  • Premium Curse Client
  • and many More Features
  • Learn More »

Leaguepedia PAX Skin Giveaway