Get an Epic Experience with Premium

Auc-Advanced-Searcher-Pawn

Auction & Economy Login to Add Favorites
  • 2 Likes
  • World of Warcraft
  • 363 Monthly Downloads
  • Supports: 5.4.2
  • 116,214 Total Downloads
  • Updated 12/28/2013
  • Created 03/11/2009
  • 121 Favorites
  • Project Site
  • Comments
  • Release Type: Release
  • License: GNU General Public License version 3 (GPLv3)
  • Newest File: v1.5.2
or
Support development! **
Donate

About Auc-Advanced-Searcher-Pawn

Description

This addon helps you FIND BETTER GEAR (Armor, Weapons, Trinkets etc) on the auction house. It uses the Pawn addon to compare what you are currently wearing with the items for sale on the auction house.

Requirements

This addon REQUIRES both PAWN and AUCTIONEER SUITE to be installed

Installation Notes

When you install this addon by Curse-client then it will install Auctioneer and Pawn (if needed) automatically or you can install them manually by yourself.

Localization

100% Localized as of v1.4.3. Did a lot of it with google translate, so please offer suggestions / corrections as needed.

Your participation is welcome on our Localization site.

How To Use

Standard Use

  • Scan Auction House by Auctioneer Scan function
  • Click Search Tab of Auctioneer
  • Expand Searchers and select Pawn
  • Select the Scale that has been defined in the Pawn addon (for example: scales for wowhead.warlock.affliction)
  • Select other options if needed
  • Click Search
  • See/Buy/Bid BETTER GEAR in search result window

Real-time Use

  • Ensure that Pawn is selected in the list of searchers to use for Real-time Searches
  • Activate Realtime scanner

BUG Reporting

Please report Bugs by writing Tickets.

Issues I'm working on

  • Code optimization
  • Localization system

Authors

  • Xit_Draka - Maintainer, Author and Developer.
  • ShadowVall - Localization (Russian) and Debugging.

Special Thanks to

MGotovcev - My (ShadowVall) entry point to this project, lua-coding and CurseForce development. Thank you very much.

------------------------------------------------------------------------
r107 | xit_draka | 2013-12-28 20:12:40 +0000 (Sat, 28 Dec 2013) | 1 line
Changed paths:
   A /tags/v1.5.2 (from /trunk:106)

Tagging as v1.5.2
------------------------------------------------------------------------
r106 | xit_draka | 2013-12-28 20:11:48 +0000 (Sat, 28 Dec 2013) | 1 line
Changed paths:
   M /trunk/Localization/localization.de.lua
   M /trunk/Localization/localization.en.lua
   M /trunk/Localization/localization.esES.lua
   M /trunk/Localization/localization.esMX.lua
   M /trunk/Localization/localization.fr.lua
   M /trunk/Localization/localization.it.lua
   M /trunk/Localization/localization.koKR.lua
   M /trunk/Localization/localization.pt.lua
   M /trunk/Localization/localization.ru.lua
   M /trunk/Localization/localization.zhCN.lua
   M /trunk/Localization/localization.zhTW.lua
   M /trunk/SearcherPawn.lua
   M /trunk/auc-advanced-searcher-pawn.toc

* Removed Ranged.  The slot is not in existence anymore, and the formerly ranged weapons are now considered main hand weapons.
------------------------------------------------------------------------

Addon Packs Containing This...

Comments

  • #89
    Re: Auc-Advanced-Searcher-Pawn Error

    Received this error on opening the guild bank today:

    Date: 2014-02-14 10:15:31
    ID: 2
    Error occured in: Global
    Count: 1
    Message: ...AddOns\Auc-Advanced\Libs\LibExtraTip\LibExtraTip.lua line 387:
    Usage: GameTooltip:SetHyperlink(link)
    Debug:
    [C]: ?
    [C]: ?
    ...AddOns\Auc-Advanced\Libs\LibExtraTip\LibExtraTip.lua:387:
    ...AddOns\Auc-Advanced\Libs\LibExtraTip\LibExtraTip.lua:381
    [C]: Outfitter_OrigSetHyperlink()
    Outfitter\Outfitter.lua:7938: SetHyperlink()
    Skillet\UI\ShoppingList.lua:123: ShoppingListButton_OnEnter()
    [string "*:OnEnter"]:1:
    [string "*:OnEnter"]:1
    Locals:

    AddOns:
    Swatter, v5.20.5446 (RidiculousRockrat)
    WowheadLooter, v50014
    NPCScan, v5.4.2.6
    NPCScanOverlay, v5.4.2.1
    AckisRecipeList, v2.6.1
    Altoholic, v5.4.001
    AltoholicSummary, v5.4.001
    Atlas, v1.26.02
    AtlasBattlegrounds, v1.26.00
    AtlasBurningCrusade, v1.26.00
    AtlasCataclysm, v1.26.00
    AtlasClassicWoW, v1.26.00
    AtlasDungeonLocs, v1.26.00
    AtlasOutdoorRaids, v1.26.00
    AtlasScenarios, v1.26.00
    AtlasTransportation, v1.26.04
    AtlasWorldEvents, v3.06
    AtlasWrathoftheLichKing, v1.26.00
    AtlasLoot, vv7.07.01
    AtlasLootCataclysm, vv7.07.01
    AtlasLootClassicWoW, vv7.07.01
    AtlasLootLoader, vv7.07.01
    AtlasLootMistsofPandaria, vv7.07.01
    AucAdvanced, v5.20.5446 (RidiculousRockrat)
    aucadvancedsearcherpawn, v1.5.2
    AucFilterBasic, v5.20.5446 (RidiculousRockrat)
    AucFilterOutlier, v5.20.5446.5437(/embedded)
    AucMatchUndercut, v5.20.5446.5364(/embedded)
    AucScanData, v5.20.5446 (RidiculousRockrat)
    AucStatHistogram, v5.20.5446 (RidiculousRockrat)
    AucStatiLevel, v5.20.5446 (RidiculousRockrat)
    AucStatPurchased, v5.20.5446 (RidiculousRockrat)
    AucStatSales, v5.20.5446.5376(/embedded)
    AucStatSimple, v5.20.5446 (RidiculousRockrat)
    AucStatStdDev, v5.20.5446 (RidiculousRockrat)
    AucStatWOWEcon, v5.20.5446.5323(/embedded)
    AucUtilAHWindowControl, v5.20.5446.5347(/embedded)
    AucUtilAppraiser, v5.20.5446.5438(/embedded)
    AucUtilAskPrice, v5.20.5446.5347(/embedded)
    AucUtilAutoMagic, v5.20.5446.5443(/embedded)
    AucUtilCompactUI, v5.20.5446.5444(/embedded)
    AucUtilEasyBuyout, v5.20.5446.5427(/embedded)
    AucUtilFixAH, v5.20.5446 (RidiculousRockrat)
    AucUtilItemSuggest, v5.20.5446.5417(/embedded)
    AucUtilPriceLevel, v5.20.5446.5444(/embedded)
    AucUtilScanButton, v5.20.5446.5403(/embedded)
    AucUtilScanFinish, v5.20.5446.5347(/embedded)
    AucUtilScanProgress, v5.20.5446.4979(/embedded)
    AucUtilScanStart, v5.20.5446.5347(/embedded)
    AucUtilSearchUI, v5.20.5446.5373(/embedded)
    AucUtilSimpleAuction, v5.20.5446.5415(/embedded)
    AucUtilVendMarkup, v5.20.5446.4828(/embedded)
    Babylonian, v5.1.DEV.332(/embedded)
    BagBrother, v
    Bagnon, v5.4.9
    BankStack, vv33
    BattlePetBreedID, v1.1.1
    BattlePetCount, v1.7.4
    BattlePetQualityNotifier, v1.3.0
    BeanCounter, v5.20.5446 (RidiculousRockrat)
    CollectMe, v2.4.8
    Configator, v5.1.DEV.359(/embedded)
    Cromulent, v50400-1
    CurseProfiler, v
    DailyTamerCheck, v
    DataStore, v5.4.001
    DataStoreAchievements, v5.4.001
    DataStoreAgenda, v5.4.001
    DataStoreAuctions, v5.4.001
    DataStoreCharacters, v5.4.001
    DataStoreContainers, v5.4.001
    DataStoreCrafts, v5.4.001
    DataStoreCurrencies, v5.4.001
    DataStoreInventory, v5.4.001
    DataStoreMails, v5.4.001
    DataStorePets, v5.4.001
    DataStoreQuests, v5.4.001
    DataStoreReputations, v5.4.001
    DataStoreSpells, v5.4.001
    DataStoreStats, v5.4.001
    DataStoreTalents, v5.4.001
    DBMCore, v
    DBMLDB, v
    DBMStatusBarTimers, v
    DebugLib, v5.1.DEV.337(/embedded)
    Decursive, v2.7.3.1
    Dominos, v5.4.8
    DominosBufftimes, v
    DominosCast, v
    DominosEncounter, v
    DominosXP, v
    EasyMail, v
    Enchantrix, v5.20.5446 (RidiculousRockrat)
    EnchantrixBarker, v5.20.5446 (RidiculousRockrat)
    FBBroker, v1.19n
    FBMergeDatabase, v1.2p
    FBOutfitDisplayFrame, v1.3
    FBTrackingFrame, v1.2p
    FishingBuddy, v1.3b Beta 1
    Gatherer, v4.4.0
    GearScore, v5.2.0
    GuildBankSearch, v5.0.0.1
    HealBot, v5.4.2.1
    HealBotTips, v5.4.2.1
    InFlightLoad, v5.4.001
    Informant, v5.20.5446 (RidiculousRockrat)
    LibExtraTip, v5.12.DEV.355(/embedded)
    LibSharedMedia30, v3.0-81
    LightHeaded, v365
    MogIt, v3.1.6
    MogItHighlighter, vv1.1
    Molinari, v50300.26-Release
    Outfitter, v5.9.3
    Pawn, v1.8.11
    PetBattleTeams, v3.2.5
    PetTracker, v
    PetTrackerBreeds, v
    PetTrackerJournal, v
    PetTrackerSwitcher, v
    PetTrackerUpgrades, v
    QuestCompletist, v100.0
    QuestGuru, v2.2.18-50400
    QuestGuruTracker, v2.2.18-50400
    Rarity, v1.0
    RarityOptions, v
    Recount, v
    SimpleCoords, v2.01
    Skillet, v
    SlideBar, v5.20.5446 (RidiculousRockrat)
    Spellcraft, v
    Stubby, v5.20.5446 (RidiculousRockrat)
    TabardMaster, v106
    TillerTracker, v1.13.1
    TipHelper, v5.12.DEV.351(/embedded)
    Titan, v5.2.3.50400
    TitanGold, v5.2.3.50400
    TitanHealBot, v5.3.0.8
    TitanXP, v5.2.3.50400
    TomTom, vv50400-1.0.0
    WIM, v3.6.13
    WoWDBProfiler, v
    XBar, v4.13
    XBuffBar, v4.05
    XHealBar, v4.05
    XPetStuffBar, v4.06
    XRogueBar, v4.03
    XTotemBar, v4.05
    XTradeBar, v4.05
    XTrapBar, v4.03
    XWarlockBar, v4.04
    BlizRuntimeLib_enUS v5.4.2.50400 <us>
    (ck=119b)

     

  • #86

    Pawn is now a required dependency.  If you are having issues with Pawn due to localization issues, please visit the Pawn project localization page http://wow.curseforge.com/addons/pawn/localization/ and help them out.

    Pawn needs help verifying Portuguese, French, and Traditional Chinese.  And they need help localizing Italian, Korean, and both Spanish languages.  If you speak one of these languages and use WoW in that language, please help them out!

  • #82

    100% Localized as of v1.4.3. Did a lot of it with google translate, so please offer suggestions / corrections as needed.

    Link to localization site on curseforge.com: Localization Page


    Enhancements and Bug Reports on curseforge.com: Tickets

     

    Last edited by Xit_Draka on 10/9/2012 11:53:13 AM
  • To post a comment, please login or register a new account.
Login to Curse

Don't have an account? Create One.

Get an epic experience with Curse Premium
  • Faster addon downloads
  • Premium-Only Beta Giveaways
  • Ad-Free Curse experience
  • Premium Curse Client
  • and many More Features
  • Learn More »

Leaguepedia PAX Skin Giveaway