Get an Epic Experience with Premium

Bartender4

Action Bars Login to Add Favorites
  • 240 Likes
  • World of Warcraft
  • 571,688 Monthly Downloads
  • Supports: 6.0.3
  • 21,020,570 Total Downloads
  • Updated 01/17/2015
  • Created 09/14/2008
  • 18,222 Favorites
  • Project Site
  • Comments
  • Release Type: Release
  • License: All Rights Reserved
  • Newest File: 4.6.6
or
Support development! **
Donate

About Bartender4

Bartender4 is a full ActionBar replacement mod. It provides you with all the features needed to fully customization most aspects of your action and related bars.

WoW 6.0 and Warlords of Draenor

The latest version of Bartender (4.6.0) is fully compatible with WoW 6.0 and Warlords of Draenor!

Features

  • Support for all Action Bars and all related bars
    • 10 Action Bars
    • Stance Bar
    • Pet Bar
    • Bag Bar
    • Micro Menu
    • XP/Reputation Bar
  • All Bars are fully customizable (Scale, Alpha, Fade-Out settings, ...)
  • Very flexible and customizable Show/Hide driver based on Macro Conditions
  • Additional Layout and Paging settings for Action Bars
    • Page all bars based on Stance or Modifier
    • Possess Bar support
    • Custom State driver support with Macro Conditions
  • Options to hide specific elements of the buttons (Macro Text, HotKey, more could be added on demand)
  • StickyFrames support
  • Masque/ButtonFacade support!
  • Easy Hotkey Binding using KeyBound
  • Options to control the hiding of the default blizzard artwork (you might still want that to be displayed..)

FAQ

Q: How do i access the Configuration?
A: You can open the configuration with the Slash Commands (/bt or /bartender) or through the Bartender4 LDB plugin.

Q: Can Bartender4 import settings from Bartender3?
A: No. Those two mods are too different to be able to import settings.

Q: Where are my keybindings? And how do i bind new keys?
A: BT3 Keybindings will not be ported over either, you have to use the new KeyBound to re-bind your keys. You can access KeyBound by its slash command (/kb) or through the button in the BT4 config. Hover a button, press key → voila!

Q: CyCircled Support? I like my button skins? :(
A: No reason to cry! There is a sparkling new skinning addon/library out there! ButtonFacade is way easier to work with as a action-bar author, and its easier to write skins for it too! Alot of cyCircled Skins have already been ported to ButtonFacade, and more are on their way! After installing ButtonFacade just use its configuration to change the skin of the BT4 buttons (/bf)

Q: How do i disable the snapping of the bars?
A: Currently, you can temporarily override the snapping by holding down the Shift Key while moving your bars, or uncheck the option in the popup when your bars are unlocked.

Feature Requests/Bug Tracker

Please submit Bugs and/or Feature Requests using the Ticket System on the WoWAce Project page or in the Bartender4 Forum Thread. Please provide as many information as possible, including your client language, the exact version you are running, how to reproduce any errors, and a stack trace, if applicable.

WoWAce Project: Bartender4 on WoWAce
Custom State Header: Info page on WoWAce
Forums: Bartender4 Forum Thread
ButtonFacade: WoWAce ButtonFacade Project

tag 4.6.6
a08dd843b2adb99c6e434e49452579398d9fe1d8
Hendrik Leppkes <h.leppkes@gmail.com>
2015-01-17 10:26:26 +0100

Tag as 4.6.6

--------------------

Hendrik Leppkes:
    - Its 2015
    - Add LibButtonGlow-1.0 to pkgmeta and toc

Comments

First Previous Page 46 of 317 Next Last
  • #4709

    The Enable Check Box is missing on 5,6&7 bars after the update, so I can't get them to show up on my screen. I'll try re-installing, but this will be my second time doing so.  I LOVE this mod and hope it's fixed soon.  Thanks for all of the hard work you put in on it.

     

    Fixed now...4.5.8 was the answer. Thanks!

    Last edited by jamae1979 on 11/28/2012 4:15:28 PM
  • #4705

    4.58 fixed it for me...tyvm

  • #4704

    same issues with multiple bars not showing up..

  • #4703

    I don't know if it's got something to do with this recent update a few minutes to go, but my game just crashed 4 times in a row after entering Vale. Didn't do so before the addon update.

  • #4706
    Quote from soee »

    I don't know if it's got something to do with this recent update a few minutes to go, but my game just crashed 4 times in a row after entering Vale. Didn't do so before the addon update.

    My game keeps crashing after the install, i'm simply kicked out to the login window 10 secs after entering my char, i can easily run around for those 10 secs but not interact with npc's and such.

  • #4702

    Is the missing bar shit working now?

  • #4700

    Great service! Thanks :)

  • #4697

    Nevcairiel, THANK YOU for the prompt update... greatly appreciated!!! Laughing

  • #4696

    I have 4.5.6. 4 and 5 bars are broken.

    Date: 2012-11-28 15:38:34
    ID: 3
    Error occured in: Global
    Count: 12
    Message: ..\AddOns\Bartender4\Options\ActionBar.lua line 33:
       Invalid bar id in options table. (4)
    Debug:
       (tail call): ?
       [C]: ?
       Bartender4\Options\ActionBar.lua:33:
          Bartender4\Options\ActionBar.lua:31
       Bartender4\Options\ActionBar.lua:46: member()
       ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:249:
          ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:197
       ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1145:
          ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1055
       ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1588: FeedGroup()
       ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1513:
          ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1493
       (tail call): ?
       [C]: ?
       [string "safecall Dispatcher[3]"]:9:
          [string "safecall Dispatcher[3]"]:5
       (tail call): ?
       ...ace\AddOns\Bartender4\libs\AceGUI-3.0\AceGUI-3.0.lua:314: Fire()
       ...libs\AceGUI-3.0\widgets\AceGUIContainer-TabGroup.lua:156: SelectTab()
       ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1624: FeedGroup()
       ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1513:
          ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1493
       (tail call): ?
       [C]: ?
       [string "safecall Dispatcher[3]"]:9:
          [string "safecall Dispatcher[3]"]:5
       (tail call): ?
       ...ace\AddOns\Bartender4\libs\AceGUI-3.0\AceGUI-3.0.lua:314: Fire()
       ...ibs\AceGUI-3.0\widgets\AceGUIContainer-TreeGroup.lua:504: SetSelected()
       ...ibs\AceGUI-3.0\widgets\AceGUIContainer-TreeGroup.lua:192:
          ...ibs\AceGUI-3.0\widgets\AceGUIContainer-TreeGroup.lua:188


  • #4699

    Fixed in 4.5.8. Thanks! :)

  • #4695

    I am having the same problem it appears many others are having, bars 4-6 for me are not responding and giving the following error...

    Date: 2012-11-28 16:40:34
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ...er4\libs\LibActionButton-1.0\LibActionButton-1.0.lua line 1224:
    Usage: FlyoutHasSpell(flyoutID, spellID)
    Debug:
    [C]: FlyoutHasSpell()
    ...er4\libs\LibActionButton-1.0\LibActionButton-1.0.lua:1224:
    ...er4\libs\LibActionButton-1.0\LibActionButton-1.0.lua:1218
    ...er4\libs\LibActionButton-1.0\LibActionButton-1.0.lua:1028:
    ...er4\libs\LibActionButton-1.0\LibActionButton-1.0.lua:964
    ...er4\libs\LibActionButton-1.0\LibActionButton-1.0.lua:960: UpdateAction()
    ...er4\libs\LibActionButton-1.0\LibActionButton-1.0.lua:438: UpdateState()
    ...er4\libs\LibActionButton-1.0\LibActionButton-1.0.lua:420: SetState()
    Bartender4\ActionBar.lua:124: UpdateButtons()
    Bartender4\ActionBar.lua:35: ApplyConfig()
    Bartender4\ActionBars.lua:182: Create()
    Bartender4\ActionBars.lua:80:
    Bartender4\ActionBars.lua:72
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[1]"]:9:
    [string "safecall Dispatcher[1]"]:5
    (tail call): ?
    ...\AtlasLoot_Loader\Libs\AceAddon-3.0\AceAddon-3.0.lua:543: EnableAddon()
    ...\AtlasLoot_Loader\Libs\AceAddon-3.0\AceAddon-3.0.lua:556: EnableAddon()
    ...\AtlasLoot_Loader\Libs\AceAddon-3.0\AceAddon-3.0.lua:636:
    ...\AtlasLoot_Loader\Libs\AceAddon-3.0\AceAddon-3.0.lua:621
    [C]: LoadAddOn()
    ..\FrameXML\UIParent.lua:299: UIParentLoadAddOn()
    ..\FrameXML\UIParent.lua:373: TimeManager_LoadUI()
    ..\FrameXML\UIParent.lua:690:
    ..\FrameXML\UIParent.lua:657
    Locals:
    None
    AddOns:
    Swatter, v4.0.6 (<%codename%>)
    NPCScan, v5.0.0.5
    AtlasLootLoader, vv7.04.00
    Babylonian, v5.1.DEV.332(/embedded)
    Bartender4, v4.5.6
    Combustion, v2012-11-27
    Configator, v5.1.DEV.344(/embedded)
    DBMCore, v
    Gatherer, v4.0.6
    Recount, v
    SlideBar, v4.0.6 (<%codename%>)
    BlizRuntimeLib_enUS v5.1.0.50100 <us>
    (ck=144)

     

  • #4698

    Edit, downloaded the newest version and no more errors, muchos gracias.

  • #4694

    The 5.8 Patch seems to have fixed the issue - thank you!

  • #4692

    4.5.8 - My bars are back!

  • #4691

    4.5.7 still unable to enable bars 4,5,6 on my warlock.  Ok on my shaman I can not enable bars 1,3,4,5,6  I am using elvui also.

    Last edited by Dyabetuz on 11/28/2012 3:33:29 PM
  • To post a comment, please login or register a new account.
Login to Curse

Don't have an account? Create One.

Get an epic experience with Curse Premium
  • Faster addon downloads
  • Premium-Only Beta Giveaways
  • Ad-Free Curse experience
  • Premium Curse Client
  • and many More Features
  • Learn More »

Gamepedia Free-shirt Giveaway