Get an Epic Experience with Premium

Bitten's SpellFlash: Druid

Druid Login to Add Favorites
  • 29 Likes
  • World of Warcraft
  • 199,268 Monthly Downloads
  • Supports: 6.1.0
  • 2,976,245 Total Downloads
  • Updated 02/24/2015
  • Created 05/02/2012
  • 522 Favorites
  • Project Site
  • Comments
  • Release Type: Release
  • License: All Rights Reserved
  • Newest File: 60100.201502241807
or

About Bitten's SpellFlash: Druid

This module flashes suggested spells for all four Druid specs. You can find *lots* more information on its website.

If you download using the Curse Client it will come with everything you need. If you download your addons manually, you must also get SpellFlash.

Please see the FAQ before posting a question. If that doesn't address your issue, or you have a suggestion to improve this addon, please either leave a comment or create a ticket.

Bitten's SpellFlash modules replace Blizzard's default proc highlighting to flash the button you should press next to achieve maximum dps on a boss fight. Or if you are a tank, to maximize your survivability. For healers, they are just slightly smarter proc highlighters. Dps modules follow or are similar to priority schemes found in SimulationCraft and/or Icy Veins. Sometimes you have to be smarter than SpellFlash, e.g. when saving a cooldown for a specific boss mechanic, but in general following the recommendations will improve most people's performance.

Some modules have AoE modes. Check the descriptions of each rotation to see if one is available for the spec(s) you use.

------------------------------------------------------------------------
r163 | slippycheeze | 2015-02-25 02:11:26 +0000 (Wed, 25 Feb 2015) | 1 line
Changed paths:
   A /tags/60100.201502241807 (from /trunk:162)

Create tag 60100.201502241807
------------------------------------------------------------------------
r162 | slippycheeze | 2015-02-25 02:10:02 +0000 (Wed, 25 Feb 2015) | 1 line
Changed paths:
   M /trunk/BittensSpellFlash_Druid.toc

Bump TOC for patch 6.1
------------------------------------------------------------------------
r160 | slippycheeze | 2015-02-16 21:42:39 +0000 (Mon, 16 Feb 2015) | 1 line
Changed paths:
   M /trunk/src/Spells.lua

Hotfix for Pulverize: don't flash without enough lacerate stacks
------------------------------------------------------------------------
r158 | slippycheeze | 2015-02-16 08:36:11 +0000 (Mon, 16 Feb 2015) | 1 line
Changed paths:
   M /trunk/src/Rotations.lua

Added sunfire to pre-combat flashing
------------------------------------------------------------------------
r157 | slippycheeze | 2015-02-16 07:39:55 +0000 (Mon, 16 Feb 2015) | 9 lines
Changed paths:
   M /trunk/src/Spells.lua

Avoid flashing Sunfire constantly when Moonfire is not applied

When target switching, if you are in the solar phase (eg: sunfire
available), and moonfire was not already present on the target, we would
constantly flash sunfire -- because the API treats the two spells
identically, so special support is needed to filter out conditions where
they shouldn't flash.

This updates the code to avoid moonfire when it is not castable.
------------------------------------------------------------------------
r155 | slippycheeze | 2015-02-16 06:56:39 +0000 (Mon, 16 Feb 2015) | 1 line
Changed paths:
   M /trunk/src/IDs.lua
   M /trunk/src/Rotations.lua
   M /trunk/src/Spells.lua

Implement WoD Balance rotation
------------------------------------------------------------------------
r153 | slippycheeze | 2015-02-15 22:14:03 +0000 (Sun, 15 Feb 2015) | 1 line
Changed paths:
   M /trunk/src/IDs.lua
   M /trunk/src/Rotations.lua
   M /trunk/src/Spells.lua

Implement WoD bear rotation
------------------------------------------------------------------------
r151 | slippycheeze | 2015-01-25 20:56:15 +0000 (Sun, 25 Jan 2015) | 1 line
Changed paths:
   M /trunk/src/Localization.lua

Fix localization use
------------------------------------------------------------------------
r150 | slippycheeze | 2015-01-25 20:06:45 +0000 (Sun, 25 Jan 2015) | 1 line
Changed paths:
   M /trunk/src/IDs.lua
   M /trunk/src/Options.lua
   M /trunk/src/Rotations.lua
   M /trunk/src/Spells.lua

Implement WoD feral druid rotation
------------------------------------------------------------------------
r149 | slippycheeze | 2015-01-25 20:06:41 +0000 (Sun, 25 Jan 2015) | 1 line
Changed paths:
   M /trunk/src/Rotations.lua

Excise custom warning code now I am finally updating this.
------------------------------------------------------------------------
r148 | slippycheeze | 2015-01-25 20:06:37 +0000 (Sun, 25 Jan 2015) | 1 line
Changed paths:
   M /trunk/BittensSpellFlash_Druid.toc
   D /trunk/src/CatSimulator.lua
   M /trunk/src/Localization.lua
   M /trunk/src/Options.lua
   M /trunk/src/Rotations.lua
   M /trunk/src/Spells.lua

Fix luacheck reported problems
------------------------------------------------------------------------

Comments

First Previous Page 17 of 19 Next Last
  • #35

    Looking forward to trying out this addon after Balance Druids are updated.  I'll be watching out.

     

    Thanks for the hard work on this...looks very promising.

  • #37

    Wait no longer!  A Balance rotation has been released.

    Author of Bitten's SpellFlash.

  • #31

    The Spellflash Modul for druids won´t work on my boomkin, but the Moduls for my priest an shaman are working perfectly. Am i doing somethung wrong with the druid modul oder is it yet not ready for 5.04? do you have any hints on that porblem xemo?#

    thanks in advance

     

    goldy

  • #32

    From the description above:

    No Balance rotation for 5.0.4 yet. Check the FAQ for my progress as I update Bitten's SpellFlash modules for 5.0.4.

    <Edit:> Balance now works.

    Last edited by Xemnosyst on 9/3/2012 12:02:12 AM

    Author of Bitten's SpellFlash.

  • #29

    Bitten's Spellflash Druid is showing as "Dependency Out of Date" and Bitten's Spellflash Library as "Out of Date" and if I choose "Load Out of Date Add-ons" when I attack a mob I get a staggery kind of lag followed by a screen freeze that only a shut-down of my computer will fix.

  • #30

    Uncheck "Load out of Date Addons", then uncheck all of them that are red except mine, then re-select "Load Out of Date Addons".  Sounds to me like you have a buch of other addons that are causing all kinds of problems if you let them load.

    Author of Bitten's SpellFlash.

  • #36

    Just popping back to let you know that your instructions fixed it.  Thank you.

  • #34
    Quote from rooney90 »

    your addon is now the only addon thats loaded out of date, and still it will not work.

    it still says dependancy out of date :( 

    If it says it's out of date, that sounds like you do not have a check mark next to "Load out of Date Addons".  That has to be selected (as the last step of my instructions above).  Remember to have SpellFlash, Bitten's SpellFlash Library, and Bitten's SpellFlash: Druid all selected.

    Author of Bitten's SpellFlash.

  • #33

    your addon is now the only addon thats loaded out of date, and still it will not work.

    it still says dependancy out of date :( 

  • #23

    The mangle change is makeing the chatbox freak out and spam 

    No spell defined (or no ID attribute): Mangle

  • #24

    Uh oh.  I'll check check it out.  Thanks.

    Author of Bitten's SpellFlash.

  • #28

    Ah HA!!  Problem found, and fixed.  You had to be solo, but not on a target dummy for it to occur (or pull aggro, or fight Ultraxion).

    Author of Bitten's SpellFlash.

  • #27

    I'm having the same issue, in Feral.

  • #26

    feral

  • #25

    Hmm - works fine for me.  Are you sure everything is updated?  Are you in Feral or Guardian?

    Author of Bitten's SpellFlash.

  • To post a comment, please login or register a new account.
Login to Curse

Don't have an account? Create One.

Get an epic experience with Curse Premium
  • Faster addon downloads
  • Premium-Only Beta Giveaways
  • Ad-Free Curse experience
  • Premium Curse Client
  • and many More Features
  • Learn More »

Dominate the Competition with Alienware