Get an Epic Experience with Premium

ChatSounds

Chat & Communication Login to Add Favorites
  • 12 Likes
  • World of Warcraft
  • 828 Monthly Downloads
  • Supports: 5.4.0
  • 124,034 Total Downloads
  • Updated 10/31/2013
  • Created 08/21/2005
  • 440 Favorites
  • Project Site
  • Comments
  • Release Type: Inactive
  • License: BSD License
  • Newest File: 0.4.6-50400
or

About ChatSounds

Description

I often miss guild and party messages popping up on my screen since they don't make a sound.
I figured I'd make a mod to solve the problem. :)

Features

  • Can play new sounds for
    • Whispers
    • Guild
    • Officer
    • Party and Party Leader
    • Raid and Raid Leader
    • Battlegrounds and BG Leader
    • Custom player joined channels
  • Force Whisper sounds for every whisper.
  • Blacklist specific custom channels (for example hidden channels joined by addons)
  • Allows users to /r after sending a whisper without getting a reply.
  • Has a Configuration Dialog Box which is accessible through the comic bubble icon next to the Chat Frame.
  • Saves its settings per character.

Configuration

  • Click the comic bubble icon on top of the Chat Frame and select 'ChatSounds' from the menu.
  • '/chatsounds' at the command prompt.
    • '/chatsounds ?' will give help for extra commands.

------------------------------------------------------------------------
r62 | dridzt | 2013-10-31 16:43:46 +0000 (Thu, 31 Oct 2013) | 1 line
Changed paths:
   A /tags/0.4.6-50400 (from /trunk:61)

Tag as 0.4.6-50400
------------------------------------------------------------------------
r61 | dridzt | 2013-10-31 16:41:57 +0000 (Thu, 31 Oct 2013) | 2 lines
Changed paths:
   M /trunk/ChatSounds.lua
   M /trunk/ChatSounds.toc
   M /trunk/ChatSoundsOptionsFrame.xml

ChatSounds:
- 5.4.1 Fixes. realmname, microbuttons taint.
------------------------------------------------------------------------
r60 | dridzt | 2013-09-11 08:38:38 +0000 (Wed, 11 Sep 2013) | 2 lines
Changed paths:
   M /trunk/ChatSounds.toc

ChatSounds:
- derp the toc update, that's a new one!
------------------------------------------------------------------------

Comments

First Previous Page 2 of 7 Next Last
  • #96

    I moved Cloudancer2 and ralnor's error reports to the ticket system

    http://www.wowace.com/addons/chat-sounds/tickets/1-5-4-1-errors/

    Check if your error is already reported.

    In the mean-time (just got back from a mini-vacation so hadn't had time to look at all my addons for 5.4.1 yet) look at Vgeran's post below for a quick fix of the realmname error.

    Will try to have a new version up shortly.

    Edit: About the taint/addon blocked error. I might be able to 'fix' it by temporarily removing ChatSounds button from the chat menu but this is Blizzard screwing up their own code.

    5.4.1 PTR Bug report.

    http://us.battle.net/wow/en/forum/topic/10261856087

    Ignored, the problem went live

    Live bug report.

    http://us.battle.net/wow/en/forum/topic/10388659115

    UI & Macros mirror post

    http://us.battle.net/wow/en/forum/topic/10388639018

    Feel free to add your voice to those if you're an addon author or user and affected.

    Maybe they'll get around to un-breaking what they broke sooner.

    For now addon authors don't have a solution, only a choice among problems:

    Should I break the map / friends frame / chat or the talents / glyphs?

    Last edited by Dridzt on 10/31/2013 5:42:18 PM
  • #92

    ChatSounds is popping up an error when you start it up now as of 5.4.1.  If you look for this text in Interface\AddOns\ChatSounds\ChatSounds.lua:

    GetCVar("realmName")

    ...and replace it with this...

    GetRealmName()

    ...then the problems should go away.  (That CVar is nil now, it seems.)

  • #94
    Quote from VgerAN »

    ChatSounds is popping up an error when you start it up now as of 5.4.1.  If you look for this text in Interface\AddOns\ChatSounds\ChatSounds.lua:

    GetCVar("realmName")

    ...and replace it with this...

    GetRealmName()

    ...then the problems should go away.  (That CVar is nil now, it seems.)

    Thanks for the tip.  Much appreciated.

  • #91

    If you could add a profiles option or have the addon save the settings from one character to another that would be awesome.

  • #86

    Awesome fix for *actual* whispers, Dridzt. Small new problem has arisen, however. It only works for real whispers. Now, ANYTIME I hit R to reply to a battle.net whispers, it opens the box like "Tell John Smith:", and lets me type... but when I hit Send, the game tells me John Smith doesn't exist. It's like it's trying to whisper-whisper John Smith, and not battle.net-whisper him.

  • #88

    I've pushed an alpha (r56) that I think will solve this issue.

    Do me a favor and test it when it shows up Smile

    At the moment the curse packager is acting up, but it should show up here eventually:

    http://www.wowace.com/addons/chat-sounds/files/

  • #89

    Works flawlessly now.  Thanks a ton!  :)

  • #87

    Ah... thanks for the report.

    I'll look into it but tell me this as I have realID features disabled from account management for my account.

    Without chat addons is the reply functionality similar to regular whispers?

    I mean if you get a battle.net tell, can you hit r /r and reply?

  • #90

    Yes, pushing R to reply to a bnet tell is the same.  See my reply above.  All works great now.  Thanks.

  • #84

    Like others, I have a new error appearing recently. If anyone sends me a tell and I hit my reply key it does like TheSteelPhantom said and shows nothing in the box. However I also get an LUA error. I have disabled all other addons and found that is coming from this one.  Thanks!

    Error occured in: Global

    Count: 1
    Message: SendChatMessage(): Unknown chat type
    Debug:
    [C]: ?
    [C]: SendChatMessage()
    ..\FrameXML\ChatFrame.lua:4079: ChatEdit_SendText()
    ..\FrameXML\ChatFrame.lua:4091: ChatEdit_OnEnterPressed()
    [string "*:OnEnterPressed"]:1:
    [string "*:OnEnterPressed"]:1
    Locals:
    (*temporary) = "ytest"
    (*temporary) = "WHISPER_INFORM"
    (*temporary) = 1

     

  • #85

    Sorry about the delay, was busy with other mods and kinda forgot about this issue.

    Should be fixed in 0.4.4-50001 when approved.

    http://www.wowace.com/addons/chat-sounds/files/

  • #83

    I love this mod and have been using it since Vanilla WoW for raid-leader posts and forcing whispers every time. However, I've noticed that the R-to-reply-without-getting-response function is not working like it used to all the previous years. Instead, if I hit R to keep replying to someone, it opens a blank text-box instead of "Tell Name: _____" automatically.

     It has screwed me up several times because if you type in a blank box and hit send, nothing happens. It sends nowhere. So I have to alt-up-arrow to get my message back, copy/paste it, and Shift-R to actually re-whisper the person what I meant to send them all along.

     I know it's a small issue and may seem trivial, but I've been using this for 7 years now and got used to it one way. Now it's broke, and I'm in shambles. :P

     Here's a screenshot of what it's doing: http://img607.imageshack.us/img607/2752/0001dt.jpg

    Last edited by TheSteelPhantom on 11/1/2012 12:45:55 AM
  • #82

    i'm haveing a problem i never had before mop

    in guild chat if some one gets a Achievement its now not playing sound ..... is there a way to fix this ?

  • #80

    is there any chance you could put a volume control into this addon as its a bit ob the quiet side or somehhow write and louder volume level in to the program cheers

  • #79

    i'm haveing a problem i never had before 4.3 , i use my own sounds that i add to the chat sounds folder & add to list as i have for a while , but since 4.3 and the latest chat sounds update , 3 of the sounds work fine , the other wont work properly , when i select the sound file for g chat for instance every time someone types in chat i get this ear pierceing screech instead of my sound , i have tried checking the sound out of wow and it works fine , i have tried re nameing the files , setting the files on other choices (instead of gchat , i tried wisp or officer etc) but the same files wont work , i can set the 3 that work to anything and they are fine , i even tried re installing the mod and setting it up again  with the same result

    i have done this for a while and it always worked perfectly in the past

    TY for any help

  • To post a comment, please login or register a new account.
Login to Curse

Don't have an account? Create One.

Get an epic experience with Curse Premium
  • Faster addon downloads
  • Premium-Only Beta Giveaways
  • Ad-Free Curse experience
  • Premium Curse Client
  • and many More Features
  • Learn More »

VIP trip to SMITE World Championship