Get an Epic Experience with Premium

Icetip

Tooltip Login to Add Favorites
  • 5 Likes
  • World of Warcraft
  • 1,133 Monthly Downloads
  • Supports: 6.0.2
  • 34,676 Total Downloads
  • Updated 10/20/2014
  • Created 07/13/2010
  • 80 Favorites
  • Project Site
  • Comments
  • Release Type: Release
  • License: GNU General Public License version 2 (GPLv2)
  • Newest File: v2.0.9
or
Support development! **
Donate

About Icetip

Icetip

Icetip is a simple, customizeable and powerful tooltip addon.

Feature

  1. Level coloured by diffculty.
  2. Border coloured with raid colors
  3. Backdrop coloring for guildies and friends.
  4. Border coloured with item's quality.
  5. Show target's target.
  6. Show target's tanlent information
  7. Show target's base information(health, power. etc)
  8. Raid Target Icon
  9. Show npc's reputation infomation with you (hostile, friend.. etc)
  10. Guild name and guild level displayed
  11. Custom tooltip's style (background, border, font.. etc)
  12. Postioning Options(anchor, offset)
  13. The tooltip is shown in specific situations, not crash in the Hallow's Day.

Feedback

Your feedfack is important! Please sumbit bugreports, localizations in your language.Have a problem? Please create a ticket on wow.curseforge.com. Like my addon? Tell Other. :D

Where to post what

tag v2.0.9
c78d00a36939280ad765d4a248b95dfe42df623a
wolftankk <wolftankk@gmail.com>
2014-10-20 23:37:08 +0800

Tag as v2.0.9

--------------------

wolftankk:
    - dump toc fix mirror bugs

Comments

First Previous Page 1 of 2 Next Last
  • #30

    Like jsz said, ilvl is not displaying correctly, any idea why? Mine wont seem to go past 519 on both chars i play but i am over 519.

  • #29
    Re: Icetip AWESOME!

    WOW! I'm speechless. Just WOW! Thank you SO much for dev'ing such a sweet addon! I've been using TipTac for years and thought I'd never find one better than that until I came across Icetip. I love you Devs! =D

  • #28

    The item level listed on IceTip tooltips is not correct. Possibly not taking into account upgraded items or just incorrect in a different way.

  • #27

    Lingering tips need to be fixed.  Like if i scan my mouse over another player quickly, the tip stays up till i hove something else that has a different tip.

  • #26

     I used a different boarder i think it was the dialog boarder, it breaks up some times when u mouse over points on the main map and diffent world items also

  • #25

    Same deal, when mouse-over another toon... :-S Hope this will be fixed soon...Yell Also... Item lvl of target is too low.. Easy to check... Mouse over your own char... Laughing

  • #24

    Addon has inpect issues.  Bugs out when trying to inspect someone.  verified it's this, as with only IceTip active I have the issue.  Disabled no problems.  Only addon running when tested.

  • #23

    Aside the last two reported by me when going to Scene and trying to set when to show Unit Frames, now every time I log in I get also this one:
    Date: 2012-08-22 19:35:36
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\Icetip\Icetip.lua line 426:
       bad argument #1 to 'pairs' (table expected, got nil)
    Debug:
       [C]: ?
       [C]: pairs()
       Icetip\Icetip.lua:426: ?()
       ...erface\AddOns\Titan\libs\AceHook-3.0\AceHook-3.0.lua:90:
          ...erface\AddOns\Titan\libs\AceHook-3.0\AceHook-3.0.lua:87
       [C]: ?
       Icetip\modules\style.lua:66:
          Icetip\modules\style.lua:64
       [C]: ?
       [C]: SetAction()
       ..\FrameXML\ActionButton.lua:579: ActionButton_SetTooltip()
       [string "*:OnEnter"]:1:
          [string "*:OnEnter"]:1

  • #22

    Seems the option to turn off displaying of talents is not actually working.

  • #21

    Thanks for fixing the bug, but found another two in v2.0.1

    When going to the configuration, selecting Scene menu got this one:

    Date: 2012-07-19 00:22:10
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\Icetip\options.lua line 97:
       attempt to index field 'modifiers' (a nil value)
    Debug:
       (tail call): ?
       Icetip\options.lua:97: member()
       ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:249:
          ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:197
       ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1300:
          ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1055
       ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1588: FeedGroup()
       ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1513:
          ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1493
       (tail call): ?
       [C]: ?

     

    And when setting the Unit frames I got this one:

    Date: 2012-07-19 00:24:40
    ID: 2
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\Icetip\options.lua line 88:
       attempt to index field '?' (a string value)
    Debug:
       (tail call): ?
       Icetip\options.lua:88:
          Icetip\options.lua:87
       (tail call): ?
       [C]: ?
       [string "safecall Dispatcher[2]"]:9:
          [string "safecall Dispatcher[2]"]:5
       (tail call): ?
       ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:799:
          ...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:614
       (tail call): ?
       [C]: ?

  • #20

    I'm getting this error with the new v2.0:
    Date: 2012-07-17 13:58:28
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\Icetip\Icetip.lua line 444:
       bad argument #1 to 'pairs' (table expected, got nil)
    Debug:
       Icetip\Icetip.lua:182: CallMethodAllModules()
       Icetip\Icetip.lua:411: ?()
       Ace3\AceHook-3.0\AceHook-3.0.lua:90:
          Ace3\AceHook-3.0\AceHook-3.0.lua:87
       [C]: ?

    Icetip keeps on working but all my configuration disappears and I can't get to the settings.

     

  • #19

    When I change the anchor offset, it doesnt move or do anything. Can you tell me what may be wrong.

  • #18
    I wanna the new one, notice when gonna take out?
  • #17
    Is there a way to change the font of the tooltip? thanks
  • #16
    I can set the Anchor to Left, Right, Top(Left/Right), Bottom(Left/Right), but I can't set the Offset to anything. I set it, and nothing happens.
  • To post a comment, please login or register a new account.
Login to Curse

Don't have an account? Create One.

Get an epic experience with Curse Premium
  • Faster addon downloads
  • Premium-Only Beta Giveaways
  • Ad-Free Curse experience
  • Premium Curse Client
  • and many More Features
  • Learn More »

VIP trip to SMITE World Championship