Get an Epic Experience with Premium

kgPanels

Artwork Login to Add Favorites
  • 18 Likes
  • World of Warcraft
  • 49,493 Monthly Downloads
  • Supports: 6.0.2
  • 1,800,196 Total Downloads
  • Updated 10/17/2014
  • Created 09/15/2008
  • 1,552 Favorites
  • Project Site
  • Comments
  • Release Type: Release
  • License: All Rights Reserved
  • Newest File: 1.19
or
Support development! **
Donate

About kgPanels

Create panels for customizing your UI, sucessor to eePanels

Wiki and FAQ

Sample Scripts

OnClick now provides a pressed and released variable you can check for.

if pressed then
  -- do mouse down actions
elseif released then
  -- do mouse up actions
end

This means your script will get called twice when someone clicks the panel.

Here is a youtube link to a video Tutorial

Ive created an Example Texture Pack.

This example pack is just a template. If you want to use it as a storage spot for your art, look at the read me file for directions on usage.

------------------------------------------------------------------------
r434 | kagaro | 2014-10-17 14:57:03 +0000 (Fri, 17 Oct 2014) | 1 line
Changed paths:
   A /tags/1.19 (from /trunk:433)

Tagging as 1.19
------------------------------------------------------------------------
r433 | kagaro | 2014-10-17 14:56:27 +0000 (Fri, 17 Oct 2014) | 1 line
Changed paths:
   M /trunk/kgPanelsConfig/kgPanelsConfig.toc

updated toc, missed as a full update
------------------------------------------------------------------------
r432 | kagaro | 2014-10-17 14:55:47 +0000 (Fri, 17 Oct 2014) | 1 line
Changed paths:
   M /trunk/kgPanels.toc

wod toc
------------------------------------------------------------------------
r430 | stanzilla | 2014-10-14 15:16:07 +0000 (Tue, 14 Oct 2014) | 1 line
Changed paths:
   M /trunk
   D /trunk/Libs

TOC update for Patch 6.0
------------------------------------------------------------------------

Comments

First Previous Page 6 of 32 Next Last
  • #829

    Hi all. Took a long break from WoW, finally getting back into it, and there's something I had on my old UI that I can't remember how to recreate (because it required a little bit of code in the kgPanels config menu).

    Essentially, I have three separate kgPanels that fit behind my Grid frames. One is sized for a 5-man party, one for a 10-man raid, and the other for a 25-man raid. I know there's something you can put in each of those frames's config that'll only make them show up for the appropriate party size.

    So, for example, if I'm soloing, none of them show. As soon as I enter a party, the 5-man one appears. If I join a raid, 10-man, or if it's 25, 25-man. So on and so forth.

    Does anyone know what I need to put in? It's two fields (I'll have to look up which), but it was something like scan party, then IF members are >2 and <11, show.

    Etc.

    Thanks!

  • #828
    I have a small suggestion.. since tiling functions don't work, could you change SetTexture call to pass true as second parameter (maybe as an option), so using texcoords larger than 1 would cause texture to wrap as intended? I tried, it works perfectly for me.
  • #826
    i'm have a problem loading artwork. i am using a mac i type the path like this: /applications/worldofwarcraft/interface/addons/kgpanelsart/punisher.tga

    i keep getting the error message that it will no load. any help or advice?
  • #827
    i just got shared media and i still can't see any other back grounds. does the size of the pic matter, it seems that the only 3 backgrounds that came with shared media which are 256x256 anything larger are or smaller like 512x256 or 256x128
  • #825
    Ok, fixed my green artwork issue and it was quite simple.

    In my textures folder I had all my Artwork (.tga) files and all of my Photoshop (.PSD) files. Here lies the problem.

    If you have 2 files of the same name regardless of extension (.png .jpeg .tga) etc etc then you'll get the green artwork issue ingame.

    This might not be a fix for everyone but I hope it helps some of you at least!
  • #824

  • #822
    Wondering if anyone has encountered this issue.

    I created different profiles for different toons, however it doesnt seem to be remembering them. All my profiles are exactly the same.

    The only thing i can think of is that i've only created one layout, do i need to create different layouts for different profiles? my panels are all the same but my artwork for each toon is different so i was assuming a different profile would remember the different artwork

    any help much appreciated.
  • #823
    I am having the exact same issue. I have 2 different profiles and form some reason I have to keep loading the profile manualy when I log onto the toon i set it up for. I am unable to locate any option that just sets that profile perminantly to that toon. Everytime i load it, it saves it for all toons. Its getting to be a pain. If you or anyone else figures this out please let us know.

    Also does anyone know some sites that have some TGA files for use. I don't have a program to make my own and there does not seem to be allot around to download.
  • #820
    Best Addon Ever !!! Thank You for keeping this updated.
  • #819
    OK so I feel nub again I thought the max was 512 the max being 1024... AMAZING. Thanks for the help again Dal
  • #818
    The Image format is important.
    http://www.wowwiki.com/API_Texture_SetTexture

    Images may be in BLP or TGA format, and must have power-of-two dimensions up to 1024 pixels. TGA images may have 8, 24, or 32 bits per pixel for grayscale, RGB, and RGBA images respectively; RLE is supported.
  • #817
    Thanks for the help. I tried all of the things below and it still wasn't working. I then downloaded some custom textures from curse and they worked perfectly so I realized I just was saving the file wrong or something of that nature. I created a completely new file in Photoshop and saved it as a 32 bits/pixel and made sure RLE compression was off and for some reason it worked.

    TBH I was probably just screwing something up cause I am retarded but thank you all for the help I can now finally set this up.
  • #816
    I was having the problem with the green images in my UI as well, and I followed the advice of rebuilding my SharedMedia database mentioned by Dalisha, but still had problems.

    Then I noticed that I had Photoshop files in the folder with the same names as the textures that I was having trouble with. I moved these out of the SharedMedia folder, rebuilt the database again, and loaded up WoW... everything was fine again, and all my previously-green textures were now displaying as expected.
  • #815
    I was having the same issue where all my custom images turned green. I had tried all the suggestion below, but after some tinkering found that for some I was able to fix just by changing the file's name. Others I had to go back into Photoshop, and save them with a different name.

    As for the SharedMedia, if you can't find the file there's a good chance you just don't have that installed. SharedMedia is media files like backgrounds, borders, fonts and stuff that you can install and then access it with other addons.
    http://wow.curse.com/downloads/wow-addons/details/sharedmedia.aspx
  • #814
    I am having the same problems and I tried to do what Dalisha said but I could not find anything named Shared Media or anything named MyMedia.bat.txt

    Not sure what the problem is but I still have it.

    -Forgive my nubness.
  • To post a comment, please login or register a new account.
Login to Curse

Don't have an account? Create One.

Get an epic experience with Curse Premium
  • Faster addon downloads
  • Premium-Only Beta Giveaways
  • Ad-Free Curse experience
  • Premium Curse Client
  • and many More Features
  • Learn More »

VIP trip to SMITE World Championship