Get an Epic Experience with Premium

Movable Holy Power

Paladin Login to Add Favorites
  • 2 Likes
  • World of Warcraft
  • 1,987 Monthly Downloads
  • Supports: 5.0.5
  • 141,016 Total Downloads
  • Updated 10/07/2012
  • Created 11/21/2010
  • 129 Favorites
  • Project Site
  • Comments
  • Release Type: Release
  • License: GNU General Public License version 3 (GPLv3)
  • Newest File: 2.04
or

About Movable Holy Power

This addon helps you track your holy power, moving (and improving) the graphics.

can move the entire thing and also scale it globally

2.04
----
fixed mouse interaction, now you can properly click thru the frame

2.03
----
back to a cloned powerbar for pitbull compatibility (and all addons that remove player UF)

2.02
----
added checkbox to make alpha blening progressive as the stacks increase
added checkbox to allow always-transparent bar when no charges available
code cleanup

2.01b (unreleased)
----
moved to internal powerbar
rewrote mount detection (ismmounted() seems broken in 5.0)

2.0 by Morfraen
----
rebuild using blizzard PaladinPowerBar instead of just 3 hardcoded images for 1-2 holy power

1.45
----
trying to change event handling to prevent frame appear when addon is disinstalled

1.44
----
toc bump
fixed error at boot, still no idea on how to fix the options reset

1.43
----
toc bump

1.42
----
main frame is now a child of UIParent
 
1.41
----
more range to x/y offset
moved saving variables to global from percharacter

1.4
---
added options to see bar in combat, mounted and in vehicle (by popular request)

1.3
---
no bar while in vehicle

1.2
---
removed bar when mounted

1.1
---
fix on scaling sliders

1.0
---
initial un-release

Comments

First Previous Page 3 of 7 Next Last
  • #78

    Unfortunately. No changes. I've even uninstalled the game and it still comes up. I've even created a new paladin and it still shows up. I am not blaming you but it really is frustrating. The thing is I don't know much about computers and addons/etc. 

    So I am not sure what is going on or what I am doing.

    P.S I did a quick check and I think I found out the problem. It conflicts with CLCRet - Addon. You actually have to manually go in there and switch it off. 

    If you go into interface/addons and click load options on the clcret addon a plus symbol appears in the add on list. Click this, choose 'appearance' & deselect 'use own bar'.

    This should fix it.

     I don't think it has anything to do with your add on. The "small minority" are probably those using CLCRet. People, like me probably assume it was your add on only cause it was directly related to it. I apologize if I came across harsh. Was just a bit frustrated seeing an annoying bar on top on my character.

    Last edited by wynterlyn16 on 5/17/2012 8:42:37 PM
  • #77

    sorry for late answer
    the script works only if addon is loaded.. but also the bar should be there only if addon is loaded.

    really confused, anything new discovered?

  • #71

    I've been having the same problem since downloading this add on. It can't just be only a few of us. Probably a few more that may be have not reported it.

    Well I downloaded the Add On and was getting 2 bars one of top of me and one right in the center of my screen (the annoying one which everyone is talking about it). I deleted the add on and was still getting the bar in the middle. I uninstalled the game and re downloaded and am still getting it.

    I've followed your steps for taking a look at it. I don't really know what to do. I am finding it kinda annoying staring a tthe bar. would appreciate any help here!

    thanks

  • #69

    I tried using this addon and it left a holy power bar in the middle of my screen  that i cannot remove.

    i have tried removing the addon *while  wow is closed*  and reloading the ui with no success.

    any help would be great :)

  • #70
    Quote from amuadiv »

    I tried using this addon and it left a holy power bar in the middle of my screen  that i cannot remove.

    i have tried removing the addon *while  wow is closed*  and reloading the ui with no success.

    any help would be great :)


    you are the 4th man that tells me about this, on almost 20k downloads.
    i still have no idea of what is happening, but this is what i can suggest

    1) logout totally (desktop)

    2) delete folder World of Warcraft\Interface\AddOns\MovableHolyPower

    3) perform a search in the WTF folder, looking for "MovableHolyPower"

    4) delete any result

    5) log again wow.

    sorry bout this

  • #76

    still no luck ><

  • #68

    On login:

    Date: 2012-04-14 23:37:00
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ...terface\AddOns\MovableHolyPower\MovableHolyPower.lua line 128:
       attempt to index global 'MovableHolyPower_data' (a nil value)
    Debug:
       [C]: ?
       ...terface\AddOns\MovableHolyPower\MovableHolyPower.lua:128: MovableHolyPower_Refresh()
       ...terface\AddOns\MovableHolyPower\MovableHolyPower.lua:87: ?()
       ...terface\AddOns\MovableHolyPower\MovableHolyPower.lua:111:
          ...terface\AddOns\MovableHolyPower\MovableHolyPower.lua:110
    AddOns:
      Swatter, v3.2.4 (<%codename%>)
      NPCScan, v4.3.0.2
      AucAdvanced, v5.13.5258 (BoldBandicoot)
      AucStatHistogram, v5.13.5258 (BoldBandicoot)
      AucStatiLevel, v5.13.5258 (BoldBandicoot)
      AucStatStdDev, v5.13.5258 (BoldBandicoot)
      AucUtilFixAH, v5.13.5258 (BoldBandicoot)
      AucUtilScanProgress, v5.13.5258.4979(5.13/embedded)
      AucUtilSimpleAuction, v5.13.5258.5210(5.13/embedded)
      Babylonian, v5.1.DEV.312(/embedded)
      CombustionHelper, v2.9.1
      Configator, v5.1.DEV.312(/embedded)
      DBMCore, v
      DebugLib, v5.1.DEV.312(/embedded)
      Gatherer, v3.2.4
      LibExtraTip, v5.12.DEV.319(/embedded)
      MovableHolyPower, v1.44
      Skada, v1.3-11
      SkadaCC, v1.0
      SkadaDamage, v1.0
      SkadaDamageTaken, v1.0
      SkadaDeaths, v1.0
      SkadaDebuffs, v1.0
      SkadaDispels, v1.0
      SkadaEnemies, v1.0
      SkadaHealing, v1.0
      SkadaPower, v1.0
      SkadaThreat, v1.0
      SlideBar, v3.2.4 (<%codename%>)
      Stubby, v5.13.5258 (BoldBandicoot)
      TipHelper, v5.12.DEV.315(/embedded)
      BlizRuntimeLib_enUS v4.3.3.40300 <us>
      (ck=3dd)

  • #65

    thanks for pointing this error out (a bit busy with bf3). its fixed in latest version i just uploaded.

  • #67

    YEAH, thanks for update!

  • #66

    Thanks for the quick update. Keep up the great work.

  • #64

    Same here... Every time i logon i get this error:

    2x MovableHolyPower\MovableHolyPower-1.43.lua:132: attempt to index a nil value
    MovableHolyPower\MovableHolyPower-1.43.lua:132: in function "MovableHolyPower_Refresh"
    MovableHolyPower\MovableHolyPower-1.43.lua:81: in function "?"
    MovableHolyPower\MovableHolyPower-1.43.lua:105: in function <MovableHolyPower\MovableHolyPower.lua:104>

    Locals:
    self = MovableHolyPower_frame {
    0 = <userdata>
    }

  • #63

    Getting this error when first logging on. It works Perfectly but the error is annoying.

     

    Date: 2011-12-24 17:29:12
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ...terface\AddOns\MovableHolyPower\MovableHolyPower.lua line 132:
       attempt to index a nil value
    Debug:
       [C]: ?
       ...terface\AddOns\MovableHolyPower\MovableHolyPower.lua:132: MovableHolyPower_Refresh()
       ...terface\AddOns\MovableHolyPower\MovableHolyPower.lua:81: ?()
       ...terface\AddOns\MovableHolyPower\MovableHolyPower.lua:105:
          ...terface\AddOns\MovableHolyPower\MovableHolyPower.lua:104
    AddOns:
      Swatter, v5.13.5241 (BoldBandicoot)
      Ace3, v
      ACP, v3.3.17
      AdvancedTradeSkillWindow, v
      Archy, v1.8.9
      Atlas, v1.21.1
      AtlasBurningCrusade, v1.21.0
      AtlasClassicWoW, v1.21.0
      AtlasWrathoftheLichKing, v1.21.0
      AtlasLootLoader, vv6.05.02
      BagBrother, v
      Bagnon, v4.3.4
      BalancePowerTracker, v1.2.6
      BindPad, v2.4.1
      BossLogger, v2
      CooldownCount, v3.81
      DamnTooltipIcons, v
      DBMCore, v
      DebugLib, v5.1.DEV.312(/embedded)
      EasyMail, v
      flagRSP2, v2.5.3
      Glamour, v1.4.3
      GreenRange, v
      HealBot, v4.3.0.0
      LibBabbleBoss30, v
      LibBabbleFaction30, v
      LibBabbleInventory30, v
      LibBabbleZone30, v
      LibStub, v
      MovableHolyPower, v1.43
      NeedToKnow, v4.0.01
      Omen, v3.1.5
      PallyPower, vv4.0.19
      Parrot, vv1.10.28
      PowerAuras, v4.23
      Prat30, v3.4.25      
      Prat30HighCPUUsageModules, v
      Prat30Libraries, v
      Quartz, v3.0.8
      RatingBuster, v
      Recount, v
      ReforgeLite, v1.09.2
      RobBossMods, v
      SellOMatic2, va044
      SellOMatic2Class, va044
      SellOMatic2Destroy, va044
      SellOMatic2Item, va044
      SellOMatic2List, va044
      SlideBar, v5.13.5241 (BoldBandicoot)
      Stubby, v5.13.5241 (BoldBandicoot)
      TidyPlates, v6.4.8.5 (R364)
      TidyPlatesThreatPlates, v5.4
      TidyPlatesHub, v
      TidyPlatesWidgets, v
      Titan, v5.0.10.40300 - Revision 519
      TitanBag, v5.0.10.40300
      TitanClock, v5.0.10.40300
      TitanCurrTrack, v1.2.9
      TitanGold, v5.0.10.40300
      TitanLocation, v5.0.10.40300
      TitanPerformance, v5.0.10.40300
      TitanRepair, v5.0.10.40300
      TitanVolume, v5.0.10.40300
      TitanXP, v5.0.10.40300
      TomTom, vv40300-1.4.4
      XPerl, v3.2.0
      XPerlArcaneBar, v
      XPerlParty, v
      XPerlPartyPet, v
      XPerlPlayer, v
      XPerlPlayerBuffs, v
      XPerlPlayerPet, v
      XPerlRaidAdmin, v
      XPerlRaidFrames, v
      XPerlRaidHelper, v
      XPerlRaidMonitor, v
      XPerlRaidPets, v
      XPerlTarget, v
      XPerlTargetTarget, v
      BlizRuntimeLib_enUS v4.3.0.40300 <us>
      (ck=741)

  • #62
    Quote from eviloz»
    this sounds like big news. will dig into this immediatly

     

    well i did a ton of experimentation, still not able to reproduce the bug :(

    Last edited by eviloz on 12/21/2011 12:11:13 PM
  • #61

     

    Quote from Smackybear »

    Btw, to repro the Alpha/Size reset bug just go into your interface menu WITHOUT going into the MovableHolyPower settings.  When you exit the interface menu the alpha and size will be reset.

    If you go into the MovableHolyPower settings while in the interface menu, the reset will not occur.

    this sounds like big news. will dig into this immediatly

  • #60

    Btw, to repro the Alpha/Size reset bug just go into your interface menu WITHOUT going into the MovableHolyPower settings.  When you exit the interface menu the alpha and size will be reset.

    If you go into the MovableHolyPower settings while in the interface menu, the reset will not occur.

  • To post a comment, please login or register a new account.
Login to Curse

Don't have an account? Create One.

Get an epic experience with Curse Premium
  • Faster addon downloads
  • Premium-Only Beta Giveaways
  • Ad-Free Curse experience
  • Premium Curse Client
  • and many More Features
  • Learn More »

Alienware Alpha Giveaway!