Get an Epic Experience with Premium

PitBull Unit Frames 4.0

Unit Frames Login to Add Favorites
  • 47 Likes
  • World of Warcraft
  • 59,730 Monthly Downloads
  • Supports: 5.4.8
  • 3,565,041 Total Downloads
  • Updated 09/16/2014
  • Created 08/01/2008
  • 3,076 Favorites
  • Project Site
  • Comments
  • Release Type: Beta
  • License: All Rights Reserved
  • Newest File: v4.0.0-beta51
or
Support development! **
Donate

About PitBull Unit Frames 4.0

PitBull4 is a continuation of PitBull.

Differences from PitBull 3:

  • It's mostly done, but not entirely done thus why there are still only betas (despite this it is still very stable).
  • Documentation is written before functions
  • Much easier for third-party extensions.
  • Options will be much, much simpler. In 3.0, there's about 200 panels that you can mess with, it's overwhelming. I want to bring this down to somewhere around 10.
    • Layouts are defined deterministically and unit groups use the layout rather than ad-hoc layouts on a per-unit basis. This will make setting up your unit frames far, far easier.
    • Due to some decisions made, 4.0 is actually more configurable than 3.0. As a layout designer, you will have a lot more control over how things look. You can have different fonts on the same frame, different textures, more precise positioning, and a whole slough of other things.
  • CPU Efficiency will be taken much more seriously.
  • It uses Ace3 instead of Rock.

FAQ: http://www.wowace.com/addons/pitbull4.../faq/.

Guide: http://www.wowace.com/addons/pitbull4.../guide/.

If you want to help localize PitBull in your language, go to http://www.wowace.com/projects/pitbul.../localization/.

Forum thread: http://forums.wowace.com/showthread.php?t=15552...

tag v4.0.0-beta51
ecad020f6d75a04d603a1e78a08cd8f78574905d
Kyle Buller <nebula@the-syn.com>
2014-09-16 13:28:25 -0500

Tagging as v4.0.0-beta51

--------------------

Kyle Buller:
    - option to display the unit's 3D portrait as the background
    - simplify suppress_ooc updating
    - add click-through option for resource indicators
    - hard embed LibDataBroker-1.1 and assume optdep loading isn't broken
    - update "Druid mana" LuaTexts on UNIT_DISPLAYPOWER
    - use UNIT_POWER_FREQUENT instead of UNIT_POWER
    - Totems: tweak options
    - Totems: update noCooldownCount on option change
    - Aura: add an option to disable OmniCC et al. by setting noCooldownCount
    - WoD auras: hide the default cooldown text and fix the cooldown spiral

Comments

First Previous Page 109 of 257 Next Last
  • #2716
    I've been having a bit of a problem with party and raid frames. I am currently updated to the beta19.

    The main problem seems to be Pitbull not recognizing players, or associating the wrong name with players. For example: one name displayed multiple times, or in some cases a "party/raid member #2" displays in place of a player's name.

    Also, is it possible to make the aggro/debuff border "glow" instead of just replacing the border's color? To make it more easily noticeable.

    Thanks.
  • #2721
    Please add any steps you take that will replicate this issue. It was noticed in version 16, we put in a fix for version 19 but it seems there are still a few reports of it still occurring... any assistance you can give on when you see the issue would be appreciated. We are trying to track this down.

    There are a few different options on the border, thick, thin, etc, as well has design choices. You might want to try a different option to see if it achieves the look you are going for.
  • #2724
    I'm having a difficult time recreating the problem. It seems to just magically occur at random.

    Yesterday a party member went offline and afterward their name was displayed on someone else's frame. When the offline player was removed from the group the name of the other player became "party member #2".

    I just tried doing it again and it didn't mess up. I'll post back here if I run across any steps that can be taken to actually recreate it.
  • #2725
    Sometimes trying to figure out what's causing the bug is like nailing jello to a wall... not very easy. :[

    I know Shefki has been raiding with beta19 and hasn't ran into the issue at all yet. Its hard to fix what you can't see regularly :\

  • #2736
    I too am having this particular issue with party and raid frames. My steps:

    1) Create a new layout called "Party" based on "Player" layout.
    2) Go to groups and create new group called "Party"
    3) Select "Party" group.
    4) Attach "Party" Layout to "Party" group.
    5) Go to the last tab and select this group to show only when in party.
    6) Set configuration (for dummy bars) to "Party".

    You get the name "Party" in the center of your screen and it is not moveable, and no bars or frames at all to make adjustments for etc.

    This happens for anything that has to do with "Groups". If you make a unit frame on it's own everything's fine. As such, I'm being forced to use the blizzard party / raid frames ... and it blows goats!

    Remember Cubs, Papa Bear loves ya!

  • #2743
    This is not the same issue. Your issue has to do with the config mode being turned off to fix another bug.

    You can still configure your Party or raid frames. Use a singleton frame your layout and then apply to your frames or configure in a live group.

    Party frames still show up... just not the dummy version in config mode. This is not the same issue and is a separate issue.
  • #2747
    Thank you for explaining that--I've been running into the same issue as Jabouty. I absolutely love the depth of control PitBull offers; I've been pulling my hair out trying to set thing up for Cataclysm with no party information. I'm looking forward to seeing the config mode restored.
  • #2726
    We just need to flash-freeze the jello, then slowly drill a small hole through the center of it and hang it on the nail. BAM!

    I have raids this weekend, so I'll really try to remember what I'm doing if it messes up. Thanks.
  • #2730
    While most of the issues with the raid frames seem fixed, I'm having problems getting status(), isAKF(), Offline(), etc to show the status of the *correct player* once someone leaves the group.
  • #2717
    I've been having the same problem since installing the latest version too. Player names being duplicated, names being switched around, and class colors being wrong (Shaman appearing as Warriors, Hunters appearing as Druids, etc).

    Doing a /reloadui will fix it for a brief period of time.

  • #2714
    I messed around for about an hour and got Pitbull to more or less look like AG Unit Frames except for one thing. When you enable background on Pitbull its larger than the actual frame. I could not figure out how to make the background the exact same size as the unit frame so it would serve as a light darkening of my cast bar when not casting. This is purely cosmetic and it is basically working as I like now.
  • #2744
    General down to 0
  • #2701
    holy power (for paladins) isnt displayed at all with 4.0.3a. i have tried disabling and reenabling it but no luck. the dk runes and shaman totems are displayed without issues tho.
  • #2702
    I've had one other person report this. However, a paladin is my main and I haven't seen it replicated on my end. :[

    Holy Power? (for your current player layout)
    Can you try test with all other add ons turned off and just PB4?
    What version number of PB4 are you using?
  • #2706
    This is also not working for me.

    Yes it is enabled under Indicators for my current layout
    It still happens with all other AddOns disabled
    I am running version 4.0.0-beta19
  • To post a comment, please login or register a new account.
Login to Curse

Don't have an account? Create One.

Get an epic experience with Curse Premium
  • Faster addon downloads
  • Premium-Only Beta Giveaways
  • Ad-Free Curse experience
  • Premium Curse Client
  • and many More Features
  • Learn More »

VIP trip to SMITE World Championship