Get an Epic Experience with Premium

PitBull Unit Frames 4.0

Unit Frames Login to Add Favorites
  • 47 Likes
  • World of Warcraft
  • 60,267 Monthly Downloads
  • Supports: 5.4.8
  • 3,566,854 Total Downloads
  • Updated 09/16/2014
  • Created 08/01/2008
  • 3,076 Favorites
  • Project Site
  • Comments
  • Release Type: Beta
  • License: All Rights Reserved
  • Newest File: v4.0.0-beta51
or
Support development! **
Donate

About PitBull Unit Frames 4.0

PitBull4 is a continuation of PitBull.

Differences from PitBull 3:

  • It's mostly done, but not entirely done thus why there are still only betas (despite this it is still very stable).
  • Documentation is written before functions
  • Much easier for third-party extensions.
  • Options will be much, much simpler. In 3.0, there's about 200 panels that you can mess with, it's overwhelming. I want to bring this down to somewhere around 10.
    • Layouts are defined deterministically and unit groups use the layout rather than ad-hoc layouts on a per-unit basis. This will make setting up your unit frames far, far easier.
    • Due to some decisions made, 4.0 is actually more configurable than 3.0. As a layout designer, you will have a lot more control over how things look. You can have different fonts on the same frame, different textures, more precise positioning, and a whole slough of other things.
  • CPU Efficiency will be taken much more seriously.
  • It uses Ace3 instead of Rock.

FAQ: http://www.wowace.com/addons/pitbull4.../faq/.

Guide: http://www.wowace.com/addons/pitbull4.../guide/.

If you want to help localize PitBull in your language, go to http://www.wowace.com/projects/pitbul.../localization/.

Forum thread: http://forums.wowace.com/showthread.php?t=15552...

tag v4.0.0-beta51
ecad020f6d75a04d603a1e78a08cd8f78574905d
Kyle Buller <nebula@the-syn.com>
2014-09-16 13:28:25 -0500

Tagging as v4.0.0-beta51

--------------------

Kyle Buller:
    - option to display the unit's 3D portrait as the background
    - simplify suppress_ooc updating
    - add click-through option for resource indicators
    - hard embed LibDataBroker-1.1 and assume optdep loading isn't broken
    - update "Druid mana" LuaTexts on UNIT_DISPLAYPOWER
    - use UNIT_POWER_FREQUENT instead of UNIT_POWER
    - Totems: tweak options
    - Totems: update noCooldownCount on option change
    - Aura: add an option to disable OmniCC et al. by setting noCooldownCount
    - WoD auras: hide the default cooldown text and fix the cooldown spiral

Comments

First Previous Page 22 of 257 Next Last
  • #4080

    The "OnEvent" errors related to animation should be fixed in beta42.

  • #4074

    error, happening random

    Date: 2012-11-30 15:29:24
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\PitBull4\Controls\Controls.lua line 58:
       <unnamed> doesn't have a "OnEvent" script
    Debug:
       [C]: ?
       [C]: SetScript()
       PitBull4\Controls\Controls.lua:58: ?()
       PitBull4\Controls\Controls.lua:121: Delete()
       ...terface\AddOns\PitBull4\Controls\BetterStatusBar.lua:1056: onDelete()
       PitBull4\Controls\Controls.lua:111: Delete()
       ...erface\AddOns\PitBull4\ModuleHandling\BarModules.lua:394: ClearFrame()
       PitBull4\ModuleHandling\Module.lua:341: Clear()
       PitBull4\UnitFrame.lua:805: Update()
       PitBull4\UnitFrame.lua:849: UpdateGUID()
       PitBull4\Main.lua:1439:
          PitBull4\Main.lua:1427

  • #4075

    This and the other people reporting errors like it can be avoided by turning off animation on your power bars.  Blizzard broke the Get/SetScript functions on the animation groups.  I can probably work around it but this will stop the error for you for the time being.

    You may also be able to avoid the error in most game play situations by turning off the option on your power bar to Hide non-power without turning off Animation.

    Note: After making these configuration changes you may still see the error until you reload the game since the error is triggered by the cleanup of the animation group on the power bar.  If you've had the animation turned on the animation bar cleanup may still be happening and triggering the error for you.

  • #4073

    since last update target-frame is buggy. reinstalled several times without any result.

    right frame should look like left one. after reload it works for several minutes but falls back to buggy version

     

  • #4076

    Your graphic is broken but I'm guessing you're having the animation issue.  Try turning off animation on youer PowerBar and reloading and see if the issue stops happening.

  • #4086

    just broken in one single frame. other frames are working perfectly

  • #4072

    I get terrible lag when i change targets (Enemies only) using this addon. Turned all of them off one by one and when I disabled this one it fixed it. Please fix, I love this addon and use it despite the lag but i would love to have it fixed. I go from 30-60 FPS to 5-9 FPS.

  • #4077

    You're probably getting an error.  Turn on the error reporting to find out what it is.

    Given the issues with animation I'd guess that's what the issue you're having is see my suggestions above.

  • #4071

    get an error whil target or targetoftarget frame active:

    Message: Interface\AddOns\PitBull4\Controls\Controls.lua:58: <unnamed> doesn't have a "OnEvent" script
    Time: 11/28/12 19:25:26
    Count: 9719
    Stack: [C]: in function `SetScript'
    Interface\AddOns\PitBull4\Controls\Controls.lua:58: in function `?'
    Interface\AddOns\PitBull4\Controls\Controls.lua:121: in function `Delete'
    ...terface\AddOns\PitBull4\Controls\BetterStatusBar.lua:1056: in function `onDelete'
    Interface\AddOns\PitBull4\Controls\Controls.lua:111: in function `Delete'
    ...erface\AddOns\PitBull4\ModuleHandling\BarModules.lua:394: in function <...erface\AddOns\PitBull4\ModuleHandling\BarModules.lua:383>
    (tail call): ?
    Interface\AddOns\PitBull4\ModuleHandling\Module.lua:319: in function `Update'
    Interface\AddOns\PitBull4_PowerBar\PowerBar.lua:73: in function <Interface\AddOns\PitBull4_PowerBar\PowerBar.lua:50>

    Locals: (*temporary) = <unnamed> {
     0 = <userdata>
    }
    (*temporary) = "OnEvent"
    (*temporary) = nil

    Last edited by Osvaldo on 11/28/2012 12:34:39 PM
  • #4079

    Animation issue, see the suggestions above.

  • #4070

    After the update anytime I would reload ui or log out/in I would have to go into profiles and choose the profile I wanted AFTER choosing a profile that had nothing done to it.

    It also won't save any changes done to it and a lot of units that I don't have turned on (target's targets target, etc) is showing even though its not checked. (I have to check it and uncheck it to make it disappear).

     Is no one else having this issue? :/

    Last edited by Vellaella on 11/29/2012 9:48:19 AM
  • #4078

    Are you getting any errors?  Might be related to the animation issues, see my suggestions above.

  • #4084

    Message: PitBull4-v4.0.0-beta40\Main.lua:1728: Bad argument #1 to "MakeSingletonFrame". "boss5" is not a singleton UnitID
    Time: 12/01/12 00:49:47
    Count: 1
    Stack: Interface\AddOns\PitBull4\UnitFrame.lua:166: in function `func'
    Interface\AddOns\PitBull4\Main.lua:1728: in function <Interface\AddOns\PitBull4\Main.lua:1722>
    (tail call): ?
    Interface\AddOns\PitBull4\Main.lua:1325: in function `OnProfileChanged'
    Interface\AddOns\PitBull4\Main.lua:1419: in function <Interface\AddOns\PitBull4\Main.lua:1384>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[1]"]:9: in function <[string "safecall Dispatcher[1]"]:5>
    (tail call): ?
    Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:543: in function `EnableAddon'
    Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:636: in function <Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:621>
    [C]: in function `LoadAddOn'
    Interface\FrameXML\UIParent.lua:299: in function `UIParentLoadAddOn'
    Interface\FrameXML\UIParent.lua:373: in function `TimeManager_LoadUI'
    Interface\FrameXML\UIParent.lua:690: in function <Interface\FrameXML\UIParent.lua:657>

    Locals: <none>

  • #4063

    So, after today's update my chi is no longer showing up on my monk

  • #4068

    Update to beta41.

  • To post a comment, please login or register a new account.
Login to Curse

Don't have an account? Create One.

Get an epic experience with Curse Premium
  • Faster addon downloads
  • Premium-Only Beta Giveaways
  • Ad-Free Curse experience
  • Premium Curse Client
  • and many More Features
  • Learn More »

VIP trip to SMITE World Championship