Get an Epic Experience with Premium

ItemID

Miscellaneous Login to Add Favorites
  • 0 Likes
  • World of Warcraft
  • 326 Monthly Downloads
  • Supports: 5.1.0
  • 38,832 Total Downloads
  • Updated 11/30/2012
  • Created 02/09/2007
  • 25 Favorites
  • Project Site
  • Comments
  • Release Type: Inactive
  • License: All Rights Reserved
  • Newest File: Version 1.10.1
or

About ItemID

Ever want to know what the item ID is for an item your friend linked you? Well, with ItemID, all you have to do is link it an item, and it'll tell you the ID for it!

But that's not all! ItemID can output it's message in a say, yell, or to your party, guild or raid!

To use it, simply type "/itemid" then link your item! For more complex usage, see "/itemid help".

All of my Addons can now be downloaded from one convenient spot!
Visit http:code.google.com/p/kjasiwowaddons/ to get the latest versions and even updates that haven't been released!

v1.10.1
 - TOC Update for 5.1
 - Corrected revision numbers

v1.10.0
 - Updated TOC for 5.0.x
 - Put localization into an array. Please help us localize ItemID on Curseforge or WowAce!

v1.9.1
 - Updated for Currency.
 - Fixed some incorrect localizations.
 - Removed some redundant code.
 - Removed some debug messages accidentally left in the previous release.

v1.9
 - TOC Update for 4.3
 - Updated to use the new LibItemID

v1.8.3
 - TOC Update for 4.2
 - Added Current Tooltip Information. *NOTE* Does not yet work with all tooltips.
 - Extended Tooltip data.

v1.8.2 (1.8b)
 - Tooltips are now off by default, as originally intended.
 - Fixed a tooltip bug if (for some odd reason) the itemtype was nil.

Comments

First Previous Page 1 of 2 Next Last
  • #16

    Hi, in patch 5.1/5.2 it doesnt show my specialisation screen properly, hides colours and names. and on my druid it completely gets rid of Resto? any fixes?

  • #13

    Hi.

    I'm trying to use the itemlink syntax, e.g. /itemid itemlink 38577

    But I'm getting an error at ItemID.lua line 260

    The line of code is:

    result = format(L["Format Output Msg Short"],ITEMID_ITEMLINK,tostring(node))

    Basically ITEMID_ITEMLINK is nil. I can't find where it's supposed to be defined in all the codes either.

    Thanks!

    Last edited by pigeond on 1/10/2013 4:48:38 AM
  • #14

    Unfortunately, you found a bug that propped up during my format transition for the language files. enUS.lua should have a L["Type Item Link"] entry which reads "Item Link" to replace ITEMID_ITEMLINK. I guess I missed it. (I also forgot to transfer the variable names for the other link strings.)

    I've just pushed a bugfix for this to my Googlecode site, so you can download the fixed files there. I'll give ItemID a thorough look over this weekend, and release a new version once I've finished any fixes, changes or additions I think it needs.

  • #15

    Thanks for that! And thanks for your work too! Smile

  • #11

    why the addon itemid dont work in the patch 3.3.5a?... or give me the the version of it

  • #12

    Version 1.7.1 (in the Other Downloads section) should work perfectly with 3.3.5a.

  • #9
    maybe it's this along with some other addon but I was getting the following ever now and then. After patch 4.0.6 on some toons I get it every time I log in now.
    1x Blizzard_TalentUI\Blizzard_TalentUI.lua:576: attempt to index field '?' (a nil value)
    Blizzard_TalentUI\Blizzard_TalentUI.lua:505: in function

    Locals:
    self = PlayerTalentFrame {
    0 =
    TitleText = PlayerTalentFrameTitleText {}
    portrait = PlayerTalentFramePortrait {}
    TopTileStreaks = PlayerTalentFrameTopTileStreaks {}
    leftBorderBar = PlayerTalentFrameLeftBorder {}
    pet = false
    topBorderBar = PlayerTalentFrameTopBorder {}
    numTabs = 3
    talentGroup = 1
    inspect = false
    topLeftCorner = PlayerTalentFrameTopLeftCorner {}
    Inset = PlayerTalentFrameInset {}
    portraitFrame = PlayerTalentFramePortraitFrame {}
    }
    event = "PLAYER_TALENT_UPDATE"
    arg1 = nil
    selectedSpec = nil

    ---
  • #10
    I got this issue too. Can't remember if I fixed it... When I can afford some game time (or get enough paypal donations for game time) I'll try to fix this.
  • #7
    I can't for the life of me figure out why, but version 1.8 is creating a problem with Bartender4. It causes the in-game rep bar and pet bar to show up intermittently, but can be reproduced by switching spec. Took a screenshot to illustrate -- http://img219.imageshack.us/i/actionbars.jpg

    Reverting to 1.7.1 fixes the problem.
  • #8
    Yikes... The only difference between the 1.7 series and the 1.8 series is the tooltips. It doesn't mess with positioning or visibility at all... When I get more game time, I'll see if I can reproduce and fix this.
  • #5
    Turn off the annoyingly spammy and extremely buggy new tooltip features:

    /itemid tooltips hide
  • #6
    Crap, sorry. I meant to have that off by default. Must of forgotten.
  • #3
    Did this update ever take place ??
  • #4
    I didn't have time to work on it before my WoW got discontinued due to lack of funding.

    So no.
  • #1
    Why not have this info in the tooltip?
  • To post a comment, please login or register a new account.
Login to Curse

Don't have an account? Create One.

Get an epic experience with Curse Premium
  • Faster addon downloads
  • Premium-Only Beta Giveaways
  • Ad-Free Curse experience
  • Premium Curse Client
  • and many More Features
  • Learn More »

Plantronics GameCom Commander Headset Giveaway!